Update

Well it has been a while, so I thought I would give a general update on what has happened so far. Unfortunately I have to say … not much.
I’ve made some progress with the licensing side of things; I’ve broken through the Microsoft guards and procedures to have access to the volume licensed software now.  The problem is that as a ‘hoster’ you need to have a Service Provider Licensing Agreement in place.
Check. Got that.
The next step is to give Microsoft their money, you need to report monthly usage so that they can bill accordingly (you pay for the actual usage, which you again (hopefully) bill the clients for). This should be done on the SPLA essentials “site”. 
This is where most of the registration pain has originated thus far. One and a half months later I still have not been able to get access to this site (even though this is what initiated the process of getting onto the spla and volume licensing agreements in the first place). I seem to be stuck in a : “I don’t have access; No our systems show you have access; but I don’t have access; but our systems show etc.  etc. etc..” communication cycle with the various levels of support around this issue.
Besides me consuming vast amounts of pricey bandwidth trying to get through MS support, I’ve been digging up old acquaintances and everybody that I have had some amicable interactions with to see if I can at least get the word out and in the process find some leads. Things are going slow (as expected) and I have no solid leads as yet, but still going strong.